Digiscoping
Help,
Advice & Lessons for All!

Digiscoping Forum

Post Reply
Forum Home > Digiscoping Equipment > Digiscoping help needed

nickybirds
Member
Posts: 3

I own a celestron ultima 80 Ed and a  canon Eos 20D and i have been trying digiscoping with this tools with no sucess since  t-rings and adapters i get are not compatible with my scope. They seem to fit well on my camera but not on the scope, this have been kinda sad. I would really appreciate some recommedations on t-rings/adapters suitable for my gadgets. 

August 20, 2012 at 4:37 PM Flag Quote & Reply

Dannys Digiscoping
Site Owner
Posts: 372

Hi there,

Thanks for your question.

It seems odd that your T2 mount doesn't fit your scope.

Have you found the T thread on your scopes eyepiece?

Its found by pulling the rubber eye cup off. Don't unscrew it, just gently grip the rubber eye cup and pull it off. That should reveal a thread that your T2 mount should attach too.

Let me know how you get on :)

Regards

Danny.

--
August 21, 2012 at 2:49 AM Flag Quote & Reply

nickybirds
Member
Posts: 3

Danny,

Thanks alot for the help and quick reply too. I managed to attach my gadgets and even tried shooting some pixs, hmm got some way to go especially with the poor light. Tips on digiscoping are always welcomed. 

--

http://www.birdingsykeholidays.com ;

August 21, 2012 at 8:33 PM Flag Quote & Reply

Dannys Digiscoping
Site Owner
Posts: 372

No problem, I'm glad you're up and running now!

Digiscoping takes a lot of practise, and learning how to take good pics takes time.

Keep patient, and invest some time into learning, like pick a nice, sunny, wind free day to practice and you'll eventually suceed!

Good luck,

Regards

Danny

--
August 22, 2012 at 2:39 AM Flag Quote & Reply

You must login to post.